VCS5.1RP1与VCS5.1SP1RP2P3版本中VCS命令兼容性的两个差异

SYMANTEC的VCS版本虽然已经发布到6.0了,但当前主流并相对稳定的版本是5.1版本,由于我最近在SUSE10版本的OS平台上应用过VCS5.1RP1和VCS5.1SP1RP2P3两个版本,发现在结合VVR/GCO用于异地容灾方案时,这两个版本下的VCS命令的回显存在一定的差异,这就会导致你基于VCS5.1RP1版本的SHELL脚本并不能直接应用于VCS5.1SP1RP2P3版本。

总结起来主要有两点差异:
1. 在启用了VVR/GCO的异地容灾系统下,如果要针对本地集群(localclus)进行设置或查询操作,那么这两个VCS版本下的VCS命令是否要在其最后带上-localclus是不完全相同的,因此需要重新检视你的代码。

2. 为集群的资源组(Service Group)开启了GCO(Global Cluster Option)后,若两个异地集群间的心跳网络不通,那么在VCS5.1RP1版本中执行VCS查询资源或资源组的状态就看不到对端的资源或资源组信息;而在VCS5.1SP1RP2P3版本中,则是可以查询命令的回显信息中看到对端信息的(虽然状态都是OFFLINE),这就会影响SHELL脚本在做检查判断,比如:grep时出现误判的情况了。

PS:以目前的经验来看,凡是VCS版本涉及到SP或以上级别的版本升级,那么就需要重新检视你的维护脚本代码了。

转载请注明:运维派 » VCS5.1RP1与VCS5.1SP1RP2P3版本中VCS命令兼容性的两个差异

0
3.4k
1